Usuario: Contraseña:
Este sitio utiliza cookies propias y de terceros. Si continúa navegando consideramos que acepta el uso de cookies. OK Más Información.

Autor Tema: Belkin GUI Linux Versión/Password por defecto routers Belkin  (Leído 5231 veces)

0 Usuarios y 1 Visitante están viendo este tema.

Desconectado Coeman76

  • Desarrolladores
  • Trade Count: (0)
  • *****
  • Mensajes: 353
  • Colaboraciones +82/-1
  • Sexo: Masculino
  • Wifiiu fiuuuu!!!
Re:Belkin GUI Linux Versión/Password por defecto routers Belkin
« Respuesta #25 en: 27 de Marzo de 2014, 02:44:35 am »
Pues estoy mirando y al parecer sí acepta música,lo unico que debe de estar el tema en la ruta del ejecutable,pero vamos...que le puedo poner volumen y hasta ecualizador si quiero,como si me apetece poner un video...la cosa esta en saber hacerlo y bien....al tiempo las GUIs con musica y maripuri se pasa a linux jaajajaj

http://qt-project.org/doc/qt-4.8/phonon-overview.html

ese qt como mola se merece una ola oeeeeeeee xD

___________________________________________________

esto es de la docu de qt

Citar
Características
He aquí algunos ejemplos de lo que se puede hacer con las API de Qt Multimedia:
Dispositivos de audio sin procesar de acceso para la entrada y salida
Juega efectos de sonido de baja latencia
Reproducir archivos multimedia en listas de reproducción (como audio comprimido o archivos de vídeo)
Grabación de audio y comprimir
Tune y escuchar emisoras de radio, y recibir información de los programas de radio
Utilice una cámara, incluyendo visor, captura de imágenes y grabación de películas
Juega 3D audio posicional con QtAudioEngine
Decodificar archivos multimedia de audio en la memoria para el procesamiento
Acceso a los fotogramas de vídeo o buffers de audio, ya que se reproducen o se graban

jur jur
« Última modificación: 27 de Marzo de 2014, 02:52:27 am por Coeman76 »

Desconectado USUARIONUEVO

  • WSlaxdesigners
  • Trade Count: (0)
  • *****
  • Mensajes: 2196
  • Colaboraciones +103/-0
  • WifiSlax Developer
Re:Belkin GUI Linux Versión/Password por defecto routers Belkin
« Respuesta #26 en: 27 de Marzo de 2014, 03:29:58 am »
Bueno , pues ya se exactamente LO MINIMO , que necesita la gui para ejecutarse ...


usando "ldd"   ... se puede saber que librerias nos pide un ejecutable. ....

con grep , cortare para que solo busque las que me interesan en este caso ( libqt5 )

asi pues ldd , sobre el ejecutable belkin , me devuelve que me va a pedir esto


consulta de dependencias qt5 sobre el binario
Código: [Seleccionar]
ldd /root/Descargas/Belkin_32/Belkin | grep -i qt5
respuesta
Código: [Seleccionar]
        libQt5Widgets.so.5 => /usr/lib/libQt5Widgets.so.5 (0xb7152000)
        libQt5Gui.so.5 => /usr/lib/libQt5Gui.so.5 (0xb6cf8000)
        libQt5Core.so.5 => /usr/lib/libQt5Core.so.5 (0xb68bb000)


bien  , se deduciria que poniendo solo esas tres libs , sobre la ruta  /usr/lib ya deberia ejecutarse, pero no es el caso ...

saldria un mensaje de que no puede cargar el plugin "xcb"

que se encuentra en el paquet qt5 , dentro de la ruta   /usr/lib/qt5/plugins/plattforms/libxcb.so ( en slackware ...otros linux pueden tener otras ruta similar pero no exacta a esta )


que a su vez , para funcionar necesita una libreria no declarada ..ya que en si no es la gui  SI NO EL PLUGIN XCB , quien la necesita .... en este caso es


Código: [Seleccionar]
libQt5DBus.so.5

asi pues recapitulando , lo minimo para ESTA GUI EN CONCRETO , seria necesario del paquet qt5  los siguientes ficheros en sus rutas


libQt5DBus.so.5
libQt5Widgets.so.5
libQt5Gui.so.5
libQt5Core.so.5

y el plugin libxcb.so


por tanto , me sale un  paquete  "runtime"   ....de  5 megas   ;D

BENDITO STRACE ...desde que me entere de lo que hacia ya me ha sacado de varios apuros ...
strace , es un ejecutable que llamado antes de la aplicacion a ejecutar , este va haciendo una inspeccion de las peticiones a sistema ... con lo que es mas facil , ver donde falla algo ,..cuando falla.

Código: [Seleccionar]
strace /usr/bin/belkin
dejo el paquete de 5 megas ....

RECORDAD , es solo un runtime exclusivo para esta gui , otras podrian funcionar o no ... ya que incluye lo basico , la libgui ,libcore   ,pero eso no asegura que otras funcionen.

qt5_runtime-5.2.1-i486-1sw.xzm (5.04 MB)   http://www.multiupload.nl/3BO18JMSV0
« Última modificación: 27 de Marzo de 2014, 03:32:41 am por USUARIONUEVO »

Desconectado kcdtv

  • Elite Friends
  • Trade Count: (0)
  • *****
  • Mensajes: 1226
  • Colaboraciones +20/-1
  • visita www.wifi-libre.com
    • www.wifi-libre.com
Re:Belkin GUI Linux Versión/Password por defecto routers Belkin
« Respuesta #27 en: 27 de Marzo de 2014, 12:17:24 pm »
Respuesta 5  , ya se te había dado el resultado de ldd grepeado  ;)

(...)
no creo que hagan falta los "dev" si se trata de lanzar solo la aplicación ya que los "bases" tienen
libQt5Widgets.so.5,   libQt5Gui.so.5, libQt5Core.so.5
(...)

Desconectado USUARIONUEVO

  • WSlaxdesigners
  • Trade Count: (0)
  • *****
  • Mensajes: 2196
  • Colaboraciones +103/-0
  • WifiSlax Developer
Re:Belkin GUI Linux Versión/Password por defecto routers Belkin
« Respuesta #28 en: 27 de Marzo de 2014, 01:00:13 pm »
Respuesta 5  , ya se te había dado el resultado de ldd grepeado  ;)

solo he explicado ,como llegue a la conclusión de que también hacia falta la

libQt5DBus ...  que no aparece con ldd y es también necesaria para el funcionamiento del plugin libxcb.so

nada mas , y lo he explicado para que otros que no sepan como buscar el fallo , puedan hacerlo en otros escenarios.

además , reviso la respuesta 5 , y solo veo el name de las libs..y para eso no necesitas ni grepear , ni ldd ni nada..la vas ejecutando y poniéndole la lib que va pidiendo a cada vez.

pero es mucho mas rápido con ldd  , y grepear lo que nos interese.

no veo en la respuesta 5 , una explicación de como llegar hasta las libs necesarias  , solo el resultado.

no pretendo enseñarte a ti , que ya sabes de sobra , solo de dar una explicación mas detallada del proceso , para los que no saben.  :-\

y lo de strace creo también interesante que la gente sepa para que sirve ..va trazando ...el camino que intenta seguir el ejecutable para ver donde esta el obstáculo.


aclarar también  que estos procesos solo son validos cuando es un ejecutable  ( c )  , no valen para saber por que un script falla ... o si una librería necesita de otra ..solo para  ejecutables en c.

« Última modificación: 27 de Marzo de 2014, 01:08:45 pm por USUARIONUEVO »

Desconectado kcdtv

  • Elite Friends
  • Trade Count: (0)
  • *****
  • Mensajes: 1226
  • Colaboraciones +20/-1
  • visita www.wifi-libre.com
    • www.wifi-libre.com
Re:Belkin GUI Linux Versión/Password por defecto routers Belkin
« Respuesta #29 en: 27 de Marzo de 2014, 02:32:46 pm »
 ;D
Citar
además , reviso la respuesta 5 , y solo veo el name de las libs..y para eso no necesitas ni grepear , ni ldd ni nada..la vas ejecutando y poniéndole la lib que va pidiendo a cada vez.

pero es mucho mas rápido con ldd  , y grepear lo que nos interese.

 ;D  ;D Pero USER si te digo que es el resultado de ldd grepeado  es que lo es... ¿Porque te mentiría ?   :)
¿Dónde lees que digo que "voy ejecutando y poniéndole la lib que va pidiendo a cada vez"?  ???

Y sobre todo .....¿Para que hablar de esto???  :)

Lo importante es que llegaste a hacer lo funcionar ws, bravo maestro  :)

enhorrabuena

Vemos que son muy pocos MB todas distribuciones GNU-Linux incluidas lo que hace aún mas interesante este tipo de trabajos :)

Let's QT5 the world  :)
« Última modificación: 27 de Marzo de 2014, 02:34:26 pm por kcdtv »

Desconectado d1k0v

  • Awireless Elite Developer
  • Trade Count: (0)
  • *****
  • Mensajes: 2431
  • Colaboraciones +61/-1
  • Sexo: Masculino
  • Loco por el Wifi
Re:Belkin GUI Linux Versión/Password por defecto routers Belkin
« Respuesta #30 en: 27 de Marzo de 2014, 02:34:48 pm »
se comprueba si existe mplayer  ( existe en todos los linux y por defecto ya que es el reproductor por shell y todo lo demas son las "fronted user"
en awl ya no existe mplayer, tanto el oficial como por shell ahora es videolan

Y tener que tirar de wine???
cuando dije que preferia usarlo con wine solo pensaba en awl que ya viene con wine de serie,
pero con el c casi que ira en consola linuxera aparte de la wingui

además , reviso la respuesta 5 , y solo veo el name de las libs..y para eso no necesitas ni grepear , ni ldd ni nada..la vas ejecutando y poniéndole la lib que va pidiendo a cada vez.
efectivamente,
el ldd engaña mucho sobretodo a los debianeros xD
que razon tiene la frase de usa debian y sabras debian y usa slack y sabras linux, por mucho que digan que no :P

@usuario he probado esto en awl y no va bien, ya me lo mirare con tiempo,
qt5_runtime-5.2.1-i486-1sw.xzm (5.04 MB)   http://www.multiupload.nl/3BO18JMSV0

me dice esto:
Código: [Seleccionar]
This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: xcb.

Reinstalling the application may fix this problem.
Abortado
estoy buscando el feto.


cualquier paquete de qt5 deberia funcionar en cualquier linux, solo son unas extensiones como java ruby o python.


 Advertencia - mientras estabas escribiendo, una nueva respuesta fue publicada. Probablemente desees revisar tu mensaje.

ya me la he leido solo es un debianero flipando :)




el que mejor y mas rapido va y pesa menos ;D
solo queda encontrar a Belkin España


« Última modificación: 27 de Marzo de 2014, 03:34:47 pm por d1k0v »

Desconectado kcdtv

  • Elite Friends
  • Trade Count: (0)
  • *****
  • Mensajes: 1226
  • Colaboraciones +20/-1
  • visita www.wifi-libre.com
    • www.wifi-libre.com
Re:Belkin GUI Linux Versión/Password por defecto routers Belkin
« Respuesta #31 en: 27 de Marzo de 2014, 03:44:16 pm »
Citar
ya me la he leido solo es un debianero flipando

Arch linux últimamente, esta bien el rolling release para no tener que despreciar mi tiempo en tareas maquinales y aburridas como vosotros  :)
Allez Slax! 
« Última modificación: 27 de Marzo de 2014, 03:52:21 pm por kcdtv »

Desconectado USUARIONUEVO

  • WSlaxdesigners
  • Trade Count: (0)
  • *****
  • Mensajes: 2196
  • Colaboraciones +103/-0
  • WifiSlax Developer
Re:Belkin GUI Linux Versión/Password por defecto routers Belkin
« Respuesta #32 en: 27 de Marzo de 2014, 03:59:02 pm »
Arch linux últimamente, esta bien el rolling release para no tener que despreciar mi tiempo en tareas maquinales y aburridas como vosotros  :)
Allez Slax!

jajaj que carb0n ... pero se aprende mas reventado el sistema uno mismo , compilando.  :)

lo de ldd en la respuesta 5 lo volveré a mirar ,por que no lo veo...

como dijo kcdtv  "mas bien grissobregris no se ve una puta mierda"   ...   ;D ;D ;D ;D

« Última modificación: 27 de Marzo de 2014, 04:00:54 pm por USUARIONUEVO »

Desconectado maripuri

  • WWAuditor-PRO developer
  • Moderador Global
  • Trade Count: (0)
  • *****
  • Mensajes: 4814
  • Colaboraciones +235/-4
  • Sexo: Femenino
  • Scripting Girl
    • WirelessWindows
Re:Belkin GUI Linux Versión/Password por defecto routers Belkin
« Respuesta #33 en: 27 de Marzo de 2014, 07:03:30 pm »

Va a traer cola esto del QT y las GUI      ;D

musiquilla eh...     :)
WWAuditor-PRO developer
No preguntes sobre temas del foro por privado, participa en el

Desconectado d1k0v

  • Awireless Elite Developer
  • Trade Count: (0)
  • *****
  • Mensajes: 2431
  • Colaboraciones +61/-1
  • Sexo: Masculino
  • Loco por el Wifi
Re:Belkin GUI Linux Versión/Password por defecto routers Belkin
« Respuesta #34 en: 29 de Marzo de 2014, 06:35:56 pm »
Arch linux últimamente, esta bien el rolling release para no tener que despreciar mi tiempo en tareas maquinales y aburridas como vosotros  :)
Allez Slax!
eso del rolling release me suena a "te lo actualizo a lo ultimito y si programas que necesitan librerias antiguas no te funcionan te jodes, y de paso me cargo alguna configuracion"
no se si sera asi pero es lo que suelen tener las actualizaciones automaticas que nunca te hacen desperdiciar (no despreciar) el tiempo.

allez allez allez, te gusta riki martin kcdtv? :)


Share me

Digg  Facebook  SlashDot  Delicious  Technorati  Twitter  Google  Yahoo
Smf

 

Dumpper All V.x.x

DUMPPER WPS PENTESTING